0 Пользователей и 1 Гость просматривают эту тему.
  • 5 Ответов
  • 778 Просмотров
*

zeus07

  • Давно я тут
  • 680
  • 8 / 0
Здравствуйте!

На одном из сайтов клиента стоит Joomla 3.5.1. Почему-то не ищет обновления. При попытке щёлкнуть на http://prntscr.com/d2zw0d выдаёт вот такую ошибку:
Код
1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 SQL=UPDATE `#__update_sites` SET `last_check_timestamp`='0',`location`='https://update.joomla.org/core/list.xml' WHERE

Скриншот: http://prntscr.com/d2zwhg

Подсказали, как можно убрать ошибку. В файле  /administrator/components/com_joomlaupdate/models/default.php изменить:
Код
$update_site = $db->loadObject();

  if ($update_site->location != $updateURL)
на
Код
$update_site = $db->loadObject();

  if ($update_site && $update_site->location != $updateURL)

Сама ошибка пропадает. Но Joomla всё-таки не ищет обновления. Подскажите пожалуйста, как решить эту проблему?
*

fbr

  • Завсегдатай
  • 1528
  • 174 / 7
Re: Проблема с компонентом Joomla Update
« Ответ #1 : 04.11.2016, 17:54:00 »
Была у меня на одном сайте такая история
Лечение - https://www.akeebabackup.com/home/news/1666-bug-ab-4-7-0-removed-update-sites.html
В моем случае помогло)
*

zeus07

  • Давно я тут
  • 680
  • 8 / 0
Re: Проблема с компонентом Joomla Update
« Ответ #2 : 04.11.2016, 22:04:54 »
Была у меня на одном сайте такая история
Лечение - https://www.akeebabackup.com/home/news/1666-bug-ab-4-7-0-removed-update-sites.html
В моем случае помогло)
Большое спасибо! Помогло! ) Плюсик в карму вам! )
*

kamuzon

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Проблема с компонентом Joomla Update
« Ответ #3 : 15.02.2021, 03:54:17 »
А как решить эту проблему в 2021м году с учётом того, что ссылка по этой ссылке больше недоступна.
И файла master по ссылке https://github.com/akeeba/updatesitefix/archive/master.zip больше нет - у кого-нибудь может сохранился?
*

AlexB

  • Завсегдатай
  • 1973
  • 53 / 2
Re: Проблема с компонентом Joomla Update
« Ответ #4 : 15.02.2021, 07:07:48 »
В настройках компонента выберите другой сервер обновления
*

kamuzon

  • Осваиваюсь на форуме
  • 12
  • 0 / 0
Re: Проблема с компонентом Joomla Update
« Ответ #5 : 16.02.2021, 06:00:24 »
Я разобрался. Вот решение.

Вопрос решается исправлением таблицы _update_sites_extensions, чтобы записи в ней соответствовали записям из таблицы _update_sites.
А там обычно 4 записи, по крайней мере в версии 3.5.1 и 3.6.0.
Если эти две таблицы не соответствуют друг другу и id в них не соответствует таблице _extensions, то никакие сервера обновлений ниоткуда выбрать не получится.

В версии 3.6.0 появляется кнопка Перестроить в "Серверы обновлений", которая в "Менеджер расширений". Это решает процесс дальнейшего автоматического обновления.

В версии 3.5.1 такой кнопки нет.
Поэтому в версии 3.5.1 либо править таблицы, как я показал на картинках.
Либо обновлять 3.5.1 до версии 3.6.0 переписыванием файлов через ftp. И там нажимать кнопку Перестроить.

Но я этой кнопки ещё не знал, поэтому в версии 3.6.0 я отредактировал таблицы. ;))

А ошибка эта появляется при обновлении версии 2.5.28 до версии 3.5.1. Ито не у всех.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Подключение Яндекс метрики в Joomla

Автор _Мария

Ответов: 30
Просмотров: 5855
Последний ответ 02.06.2021, 14:25:40
от khan-alex
Вышел релиз безопасности Joomla 3.9.27

Автор b2z

Ответов: 9
Просмотров: 792
Последний ответ 01.06.2021, 17:01:30
от Театрал
Вышел релиз безопасности Joomla 3.9.26

Автор b2z

Ответов: 12
Просмотров: 701
Последний ответ 25.05.2021, 18:00:45
от b2z
После обновления Joomla версия 3.9.26 ошибка компонента com_widgetkit

Автор kate19

Ответов: 2
Просмотров: 280
Последний ответ 14.05.2021, 22:34:26
от sivers
500 ошибка Nginx Joomla

Автор Dram

Ответов: 0
Просмотров: 161
Последний ответ 29.04.2021, 14:41:03
от Dram