обновление Joomla 3.x

  • 10 Ответов
  • 479 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
обновление Joomla 3.x
« : 12.12.2016, 14:44:59 »
Доброго времени суток.
Не подумайте что я совсем глупый.
Не могу обновиться Joomla. Установил Joomla + freebsd и т.д. Из портов версия j3.4.6. Захожу в админку мне выскакивает, что есть 3.6.х жму обновить сейчас мне в ответ
Код
Предупреждение

Update: :Extension: Не удалось открыть https://update.joomla.org/core/sts/extension_sts.xml
внизу
Код
Установленная версия Joomla! 	     3.4.6
Последняя версия Joomla!                      3.6.4
Пакет обновления (URL)
Дополнительная информация
Смущает что нету адреса обновлений. Но в сервере обновлений вот что написано
Сервер обновлений - По умолчанию
Пользовательский сервер обновлений - https://downloads.joomla.org/
Гуглил но ничего конкретного не нашел. Я честно уже от рук отбился в поиске.
Спасибо всем не равнодушным :)

*

ChaosHead

  • Профи
  • ********
  • 4667
  • 396
Re: обновление Joomla 3.x
« Ответ #1 : 12.12.2016, 14:48:07 »
Попробуйте Расширения - Менеджер расширений - Обновить. Там нажмите кнопку Очистить (кэш обновлений) и найти обновления. Потом пробуйте снова обновить Joomla

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
Re: обновление Joomla 3.x
« Ответ #2 : 12.12.2016, 14:58:29 »
Пробовал, результат тот же.
А если тупо руками взять и перекопировать файлы с заменой старые на новые ? Кривой, но вариант ?

*

voland

  • Профи
  • ********
  • 9365
  • 421
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: обновление Joomla 3.x
« Ответ #3 : 12.12.2016, 15:13:16 »
Из портов версия j3.4.6.
А зачем ставить из портов?
Не проще ли скачать с оффсайта свеженькую, а не старую с дырками?

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
Re: обновление Joomla 3.x
« Ответ #4 : 12.12.2016, 15:17:53 »
Ну вот поэтому сейчас и пытаюсь решить эту проблему и обновиться до стабильной версии.
Если файлы перенесу с заменой от новой j 3.6.x , пойдет так ? или все таки необходимо инсталлировать ?

*

voland

  • Профи
  • ********
  • 9365
  • 421
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: обновление Joomla 3.x
« Ответ #5 : 12.12.2016, 15:19:23 »
Ну вот поэтому сейчас и пытаюсь решить эту проблему и обновиться до стабильной версии.
Фряшка вообще настроена? Или как?
Скорее всего cURL не включен

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
Re: обновление Joomla 3.x
« Ответ #6 : 12.12.2016, 15:31:51 »
Фря настроена. На ней nginx + php + MySQL. А вот про cURL спасибо буду читать. Данный вариант обрадовал ибо может в этом вся проблема, но Google данный намек не давал.

*

voland

  • Профи
  • ********
  • 9365
  • 421
  • СКАЙП утерян! Пишите в телеграм @volandku
Re: обновление Joomla 3.x
« Ответ #7 : 12.12.2016, 15:42:24 »
Фря настроена. На ней nginx + php + MySQL. А вот про cURL спасибо буду читать. Данный вариант обрадовал ибо может в этом вся проблема, но Google данный намек не давал.
Это еще не значит, что она настроена на боевые сайты.
Установка через веб-интерфейс, кроме прочего, проверяет соответсвие требований окружения движку.

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
Re: обновление Joomla 3.x
« Ответ #8 : 12.12.2016, 15:46:55 »
cURL установлен, но в php56-extension не было установлена галочка на данной опции. Сейчас переставлю php проверю что и как и отпишусь.
Благодарю.

*

puf

  • Осваиваюсь на форуме
  • ***
  • 27
  • 0
Re: обновление Joomla 3.x
« Ответ #9 : 12.12.2016, 16:58:48 »
Лед тронулся господа заседатели :) Ссылка стала доступна. Спасибо большое. Единственное теперь упри установке он пишет error invalid login. Но во первых по Google, а во вторых странно что нигде про cURL не указано в мануалах по настройке фря + Joomla.

*

ChaosHead

  • Профи
  • ********
  • 4667
  • 396
Re: обновление Joomla 3.x
« Ответ #10 : 12.12.2016, 21:29:27 »
Просто раньше обновлять можно было простой перезаливкой файлов поверх, кроме папки installation. Пока они недавно не решили обновить компонент обновления и так обновляться запретили.
А про cURL сказано здесь, что он может понадобится, но опционально: https://docs.joomla.org/Optional_Technical_Requirements
В основных технических требованиях указаны только модули Apache, про PHP нет информации: https://downloads.joomla.org/technical-requirements
Хотя сейчас получается, что он обязателен уже.