Восстановление управляемости сайта на Joomla 1.0.12 после обновления php до версии 5.5 и последовате

  • 6 Ответов
  • 520 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

Оффлайн galogen

Добрый вечер!

В свое время для сайта кафедры была использована Joomla 1.0.12, еще в далеком 2006 году. В течение всего этого времени особых проблем не возникало, хотя мысли обновления посещали неоднократно. Однако дальше размышлений не шли отчасти из-за наличия пары компонентов, которые были разработаны специально и скорее всего не выдержали бы обновлений. В последствии было понято, что можно пожертвовать этими компонентами, но поскольку сайт работал, то никаких особых действия не предпринималось.

Но тут случилась пара событий. 1 - веб-сервер решили перенести на другую ОС: ubuntu (ранее крутилось на windows), 2 - обновили php с 5.2 до 5.5.х.

В результат сайт перестал нормально функционировать:
1 - часть контента просто не отображается, не отображаются разделы и категории. Лента отображается нормально. (http://dit.isuct.ru)
2 - в админке практически невозможно обратится ни к одному компоненту, модулю, боту - просто пустая страница, либо не видно название модуля (если он на русском), нет WYSIWYG редактора, в общем сайт практически не управляемый.

Лично я серьезно выпал из joomla-сообщества на определенное время и потерял тренд развития, потому прошу помощи.

1 -подскажите, как вернуть управляемость сайта при существующем окружении
2 - подскажите можно ли обновить Joomla 1.0.12 до новейших версий и до какой посоветуете?

Спасибо.


*

Оффлайн capricorn

Цитировать
обновили php с 5.2 до 5.5.

J 1.0.* не будет работать на php 5.5.

если shared хостинг задай php 5.2
если свой сервер ставь несколько версий php, вкл 5.2

Цитировать
подскажите можно ли обновить Joomla 1.0.12 до новейших версий и до какой посоветуете?

сначала до 1.0.15. потом до 1.5 и т.д. процесс многоступенчатый.

*

Оффлайн SeBun

1 -подскажите, как вернуть управляемость сайта при существующем окружении
2 - подскажите можно ли обновить Joomla 1.0.12 до новейших версий и до какой посоветуете?
1. На сервере установить древнюю версию PHP и запустить сайт там. На новых версиях работать не будет.
2. Можно. Для этого нужно перенести данные сайта из одной базы в другую (при этом структура баз различается), изображения, переписать шаблон (или поставить новый современный). Так же можно адаптировать ваши компоненты под новую версию.

Собственно, если сайт для вас важен и планируется его использование и дальнейшее развитие, лучше перенести на последнюю версию Joomla, что позволит использовать современные технологии и обеспечит должный уровень безопасности.
« Последнее редактирование: 03.02.2017, 01:12:53 от SeBun »
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Администрирование
Ник занят | По личным вопросам не консультирую

*

Оффлайн galogen

Если небольшой, то просто руками переделать.
В принципе там весь функционал стандартный. Но я почитал рекомендации, что-то пока не очень получается. Следую совету, возникает другая ошибка. Так что пока в процессе. Хотя все проблемные места обнаружил.

*

Оффлайн galogen

J 1.0.* не будет работать на php 5.5.

если shared хостинг задай php 5.2
если свой сервер ставь несколько версий php, вкл 5.2
Я поговорю с админами, может быть так и сделают пока. А потом проапгрейдим. Там есть еще сайт, правда он на 1.0.15, сначала тоже пенки были, но их удалось исправить.

*

Оффлайн Alex Revo

В сети есть доработанная под PHP 5 Joomla 1 поколения, там если не все, то многое работает нормально. У меня есть один интернет-магазин на основе Joomla 1.0.12 который прямо сейчас работает на php 5.5.9.
Аудит сайта - Бесплатно! 10 советов по улучшению своего сайта за 1 день. Писать в личку.