0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 264 Просмотров
*

Inna

  • Захожу иногда
  • 75
  • 1 / 0
Доброго времени суток!

Уважаемые форумчане, помогите, пожалуйста!

Вывожу видео и аудио стандартными средствами Joomla (пока, точнее, только аудио) - клик по иконке "Вставить/Редактировать видео". Аудио так тоже отлично вставляется. И всё бы прекрасно, но наблюдаю странные глюки. Уже кучу знакомых попросила протестировать, и вот предварительные выводы. На компьютерах с Windows 10 всё отлично, на мобильных устройствах тоже. На компах с Windows 7 начинаются глюки - в Google Хром всё отлично, а в Опере, Мозилле и ИЕ некоторые плейеры становятся неактивными и не воспроизводят файл. Причём это как-то хаотично - то работают все, то вдруг перестают работать некоторые. Думала, может, это какой-то конфликт между расширениями. На чистой Joomla всё то же самое.

Вот ссылка на тестируемый сайт:
http://test.mefodiy.ru/index.php/kalkulyator

Можно смотреть через калькулятор - так удобнее просто, всё в одном месте - кликать по слову "Диктор" и до конца (дикторов).  Компонент калькулятора тут ни при чём, проверено без него. Можно кликнуть по раскрывающемуся меню "Выбрать голос по цене", там по пунктам то же самое.

Помогите, пожалуйста! Хотела перенести наш рабочий сайт с Joomla 1.5 на Joomla 3 (наконец-то решилась) - и такая беда... Смысл просто пропадает переходить на тройку.

Пробовала изначально выводить аудио через плагин Allvideos - та же беда. То работает, то нет.

Спасибо!
« Последнее редактирование: 12.04.2017, 23:18:32 от Inna »
*

Inna

  • Захожу иногда
  • 75
  • 1 / 0
Помогали на другом форуме, выяснилось, что это проблема отображения тэгов html5.
В Мозилле почему-то само заработало.
Для Оперы помогло это (очень неудобное решение, но что поделать) - создать копию файла mp3 в формате ogg и вывести аудио такой конструкцией:
<p><audio preload="auto" controls="controls">
<source src="images/audio/audiofile.ogg" type="audio/ogg; codecs=vorbis" />
<source src="images/audio/audiofile.mp3" type="audio/mpeg; codecs=mp3" /></audio> </p>
Попробовала два файла таким образом вывести - в Опере работает.
Но Интернет Эксплорер победить не могу... Хотя везде написано, что он поддерживает mp3 формат. Скрипт Google подключён. Ещё скачивала файл скрипта, который должен был заставить ИЕ работать, и подключала его в head - без толку. И вот это добавляла:
<meta http-equiv="X-UA-Compatible" content="IE=9" />
Не помогает. В ИЕ плейеры отображаются как попало - то работают, то не работают.
Помогите, кто знает!

PS
А почему всё-таки при использовании плагина Allvideos наблюдается такой же баг? Тут на форуме где-то писали, что он подключает Mootools, может, это как-то влияет?
« Последнее редактирование: 22.04.2017, 02:22:12 от Inna »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Не отображаются настройки модулей Joomla 3.6.5

Автор AnatolyS

Ответов: 0
Просмотров: 9
Последний ответ Сегодня в 00:58:12
от AnatolyS
Вышло обновление Joomla! до 3.8.7

Автор Raven23

Ответов: 27
Просмотров: 673
Последний ответ 19.04.2018, 23:53:24
от GeorgeRound
Вышел релиз Joomla! 3.6.3

Автор b2z

Ответов: 136
Просмотров: 11174
Последний ответ 19.04.2018, 14:53:59
от dmitry_stas
Вышло обновление Joomla! до 3.8.6

Автор Olg

Ответов: 26
Просмотров: 3896
Последний ответ 18.04.2018, 19:20:46
от zikkuratvk
Перевод сайта на Joomla 3

Автор qprizing

Ответов: 1
Просмотров: 74
Последний ответ 15.04.2018, 23:28:46
от effrit