0 Пользователей и 1 Гость просматривают эту тему.
  • 1 Ответов
  • 347 Просмотров
*

Inna

  • Захожу иногда
  • 77
  • 1 / 0
Доброго времени суток!

Уважаемые форумчане, помогите, пожалуйста!

Вывожу видео и аудио стандартными средствами Joomla (пока, точнее, только аудио) - клик по иконке "Вставить/Редактировать видео". Аудио так тоже отлично вставляется. И всё бы прекрасно, но наблюдаю странные глюки. Уже кучу знакомых попросила протестировать, и вот предварительные выводы. На компьютерах с Windows 10 всё отлично, на мобильных устройствах тоже. На компах с Windows 7 начинаются глюки - в Google Хром всё отлично, а в Опере, Мозилле и ИЕ некоторые плейеры становятся неактивными и не воспроизводят файл. Причём это как-то хаотично - то работают все, то вдруг перестают работать некоторые. Думала, может, это какой-то конфликт между расширениями. На чистой Joomla всё то же самое.

Вот ссылка на тестируемый сайт:
http://test.mefodiy.ru/index.php/kalkulyator

Можно смотреть через калькулятор - так удобнее просто, всё в одном месте - кликать по слову "Диктор" и до конца (дикторов).  Компонент калькулятора тут ни при чём, проверено без него. Можно кликнуть по раскрывающемуся меню "Выбрать голос по цене", там по пунктам то же самое.

Помогите, пожалуйста! Хотела перенести наш рабочий сайт с Joomla 1.5 на Joomla 3 (наконец-то решилась) - и такая беда... Смысл просто пропадает переходить на тройку.

Пробовала изначально выводить аудио через плагин Allvideos - та же беда. То работает, то нет.

Спасибо!
« Последнее редактирование: 12.04.2017, 23:18:32 от Inna »
*

Inna

  • Захожу иногда
  • 77
  • 1 / 0
Помогали на другом форуме, выяснилось, что это проблема отображения тэгов html5.
В Мозилле почему-то само заработало.
Для Оперы помогло это (очень неудобное решение, но что поделать) - создать копию файла mp3 в формате ogg и вывести аудио такой конструкцией:
<p><audio preload="auto" controls="controls">
<source src="images/audio/audiofile.ogg" type="audio/ogg; codecs=vorbis" />
<source src="images/audio/audiofile.mp3" type="audio/mpeg; codecs=mp3" /></audio> </p>
Попробовала два файла таким образом вывести - в Опере работает.
Но Интернет Эксплорер победить не могу... Хотя везде написано, что он поддерживает mp3 формат. Скрипт Google подключён. Ещё скачивала файл скрипта, который должен был заставить ИЕ работать, и подключала его в head - без толку. И вот это добавляла:
<meta http-equiv="X-UA-Compatible" content="IE=9" />
Не помогает. В ИЕ плейеры отображаются как попало - то работают, то не работают.
Помогите, кто знает!

PS
А почему всё-таки при использовании плагина Allvideos наблюдается такой же баг? Тут на форуме где-то писали, что он подключает Mootools, может, это как-то влияет?
« Последнее редактирование: 22.04.2017, 02:22:12 от Inna »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

[Решено. Причина не найдена] Failed to read session data Joomla 3.8.1 php 7.1.11

Автор capricorn

Ответов: 3
Просмотров: 4587
Последний ответ 19.04.2019, 19:06:49
от wishlight
rel=canonical после перехода на https ссылается на http на Joomla 3.8

Автор anbarter

Ответов: 1
Просмотров: 91
Последний ответ 15.04.2019, 13:20:14
от AlexK
Вышел релиз безопасности Joomla! 3.9.5

Автор b2z

Ответов: 19
Просмотров: 844
Последний ответ 12.04.2019, 09:31:36
от sivers
Вышел релиз безопасности Joomla! 3.9.4

Автор b2z

Ответов: 26
Просмотров: 1921
Последний ответ 09.04.2019, 18:23:10
от b2z
Автоматическая установка CMS Joomla

Автор FBM

Ответов: 8
Просмотров: 272
Последний ответ 04.04.2019, 09:45:46
от Technic