0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 1850 Просмотров
*

atyutrin

  • Осваиваюсь на форуме
  • 19
  • 1 / 0
Не могу обновить Joomla
« : 29.10.2017, 15:19:02 »
Была версия 3.1 Из компонента Joomla Update обновил до 3.2.7. Такая версия была предложена.
Теперь компонент обновления пишет :
No updates available
You already have the latest Joomla! version, 3.2.7.

Архивом с Joomla.org тоже скачать не могу.



Подскажите, что делать?
*

wishlight

  • Живу я здесь
  • 4886
  • 286 / 1
  • 300 руб очень быстрый хостинг в ЕС
Re: Не могу обновить Joomla
« Ответ #1 : 29.10.2017, 15:46:58 »
https://github.com/joomla/joomla-cms/releases

Читать форум. Роскомнадзор заблочил.
*

voland

  • Легенда
  • 11016
  • 585 / 112
  • Эта строка съедает место на вашем мониторе
*

atyutrin

  • Осваиваюсь на форуме
  • 19
  • 1 / 0
Re: Не могу обновить Joomla
« Ответ #3 : 31.10.2017, 16:36:59 »
Скачал с гита обновление 2.5 to 3.81
Заменил файлы.
Получил ошибку:
Warning: Cannot redeclare class jregistry in /home/p236446/www/new.antek38.ru/libraries/loader.php on line 670
Fatal error: Call to undefined method JApplicationHelper::getHash() in /home/p236446/www/new.antek38.ru/libraries/src/Application/CMSApplication.php on line 801

Форум читал - что ещё можно предпринять?
« Последнее редактирование: 31.10.2017, 16:42:49 от atyutrin »
*

SeBun

  • Живу я здесь
  • 3991
  • 256 / 4
  • @SeBun48
Re: Не могу обновить Joomla
« Ответ #4 : 31.10.2017, 16:57:58 »
Была версия 3.1
Скачал с гита обновление 2.5 to 3.81
Получил ошибку:

Продолжение следует?  *POPCORN*
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

atyutrin

  • Осваиваюсь на форуме
  • 19
  • 1 / 0
Re: Не могу обновить Joomla
« Ответ #5 : 31.10.2017, 17:02:41 »
Продолжение следует?  *POPCORN*
Слеудует, но я пока не знаю, что предпринять. Подскажи.

Обновление котрое я устанвавливал: "Update from Joomla! 2.5 or previous 3.x releases. "
*

SeBun

  • Живу я здесь
  • 3991
  • 256 / 4
  • @SeBun48
Re: Не могу обновить Joomla
« Ответ #6 : 31.10.2017, 17:16:29 »
Ответил в личку подробной инструкцией по обновлению. Причем один из предложенных способов с 1 ноября станет нелегальным.  ;)
Оказываю услуги по Joomla | Миграция на Joomla 3.x | Сопровождение | IT-аутсорсинг | Недорогие домены и хостинг
*

atyutrin

  • Осваиваюсь на форуме
  • 19
  • 1 / 0
Re: Не могу обновить Joomla
« Ответ #7 : 31.10.2017, 18:57:09 »
Случилось чуда и я обновил Джумлу  :D

Спасибо SeBun.

Процесс оказался длительный и наверно специфичный для состояния именно моего сайта. Поэтому описывать его не буду.

Вот мудрый совет, который оказался путеводной звездой:
Цитировать
Для обновления вашей версии нужно качать тот пакет обновлений, который предназначен именно для вашей версии, а не от 2.5. Зайдите в админке в Компоненты - Обновление Joomla, там предлагается ссылка для скачивания. Она у вас не будет работать, т.к. роскомнадзор заблокировал сервера Амазона, где лежит обновление. У вас два пути. Первое - скачать ИМЕННО ЭТОТ пакет с Гита (ссылку вам дали), закачать в папку tmp и обновиться из этого каталога, либо поднимать у себя VPN и после этого ссылки должны работать. Программ, создающих тоннель, в сети много, качайте. Тем более с 1 ноября сервера VPN начнут блокировать запрещенные сайты.
Касательно обновлений - ставьте то, что предлагает, именно эти версии. Возможно, придется поэтапно обновлять. Обновились, получилось, делаем бекап. Потом следующий пакет.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Бэкап Joomla Ошибка This extension requires FOF 3.0

Автор manm7667

Ответов: 2
Просмотров: 1455
Последний ответ 16.06.2021, 11:13:59
от Tigrubiyca
Подключение Яндекс метрики в Joomla

Автор _Мария

Ответов: 30
Просмотров: 5900
Последний ответ 02.06.2021, 14:25:40
от khan-alex
Вышел релиз безопасности Joomla 3.9.27

Автор b2z

Ответов: 9
Просмотров: 818
Последний ответ 01.06.2021, 17:01:30
от Театрал
Вышел релиз безопасности Joomla 3.9.26

Автор b2z

Ответов: 12
Просмотров: 703
Последний ответ 25.05.2021, 18:00:45
от b2z
После обновления Joomla версия 3.9.26 ошибка компонента com_widgetkit

Автор kate19

Ответов: 2
Просмотров: 282
Последний ответ 14.05.2021, 22:34:26
от sivers