0 Пользователей и 1 Гость просматривают эту тему.
  • 27 Ответов
  • 8730 Просмотров
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Сильно разочаровавшись переходом OneAll на сильно платную основу и не дождавшись нормального автономного расширения, решил написать свое. Основная задача - максимальная простота реализации. За основу был выбран самый обычный модуль, работающий на связке AJAX/PHP.

Особенности модуля:

  • расширение полностью автономное и не зависит ни от каких сторонних сервисов интеграции или библиотек;
  • есть возможность объединения существующей учетной записи с выбранными соцсетями (при отказе создастся новый пользователь с уникальным именем);
  • для сервисов, не отдающих почту (например, Вконтакт), ее адрес запрашивается отдельно;
  • после авторизации выводится мини-профиль пользователя с аватаром, обозначением сети и ссылкой на профиль в ней;
  • можно включить/отключить в настройках практически все, что угодно;
  • доступна интеграция с AceShop и JomSocial;
  • практически не требует дополнительной раскраски и подгонки под дизайн - и так все красиво и универсально, на мой взгляд.

Доступные сети:

  • Facebook
  • Twitter
  • Google
  • ВКонтакте
  • Мой Мир
  • Одноклассники

Что касается остальных сетей, то их добавлять я не вижу смысла вообще. OpenID, к сожалению, полумертв, Steam работает на OpenID, а все остальное у нас знает полтора человека. Указанной выше "великолепной шестерки" в 99% случаев должно хватить.

Прочтите внимательно инструкцию по установке (на английском), иначе модуль не будет работать!

Скачать модуль можно непосредственно в JED на этой странице.

[вложение удалено Администратором]
« Последнее редактирование: 09.10.2012, 03:17:58 от czorny »
*

waw555

  • Захожу иногда
  • 118
  • 2 / 0
Есть готовый вариант с авторизацией через STEAM?
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Есть готовый вариант с авторизацией через STEAM?

Я же написал выше, что стим под большим вопросом. То есть я вообще пока не планирую даже о нем думать.
« Последнее редактирование: 07.10.2012, 20:16:08 от czorny »
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Модуль полностью переписан, добавлены сети, изначальное сообщение обновлено. Все должно работать по идее, пользуйтесь на здоровье.
*

diki78

  • Осваиваюсь на форуме
  • 37
  • 0 / 0
А для какой версии Joomla?
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
А для какой версии Joomla?

Должно работать в 1.6 и выше - это, по сути, одна платформа. Сам я проверял в 2.5.
*

diki78

  • Осваиваюсь на форуме
  • 37
  • 0 / 0
Цитата: czorny
Прочтите внимательно инструкцию по установке (на английском), иначе модуль не будет работать!

Опять я с вопросом. То версия Joomla мне не видна, то не вижу ссылку на инструкцию по установке)

Или отсюда брать? http://joomline.ru/stati/53-komponenty/306-sozdanie-prilozhenij-dlja-socialnoj-avtoriziacii.html
« Последнее редактирование: 07.10.2012, 21:52:25 от diki78 »
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Опять я с вопросом. То версия Joomla мне не видна, то не вижу ссылку на инструкцию по установке)

Инструкция в архиве лежит.
*

Лёхин

  • Новичок
  • 1
  • 0 / 0
Доброго времени суток всем обитателям данного форума)

у меня вопрос по теме.. установил.. настройки пока прописал только на вконтакте. но когда  хочу проверить )авторизоваться( получается ошибка.. на сайте АPI надо что нибудь делать у себя на сайте??  Или нет
Вот моя ошибка(((



 что нитак подскажите пожалуйста(((
« Последнее редактирование: 18.10.2012, 21:18:25 от Лёхин »
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Предоставленной информации явно недостаточно. Ошибка странная очень. Лучше напишите мне на почту и приложите скрины настроек вконтакта, а также все необходимые данные сообщите: браузер и его версию, жумла и ее версию и т.п.
*

ifx

  • Осваиваюсь на форуме
  • 28
  • 4 / 0
Можете сделать поддержку Joomla 1.5?
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Можете сделать поддержку Joomla 1.5?

Нет, ни одно из моих новых расширений не будет поддерживать жумлу 1.5, а из всех старых будет убрана ее поддержка.
*

ifx

  • Осваиваюсь на форуме
  • 28
  • 4 / 0
Нет, ни одно из моих новых расширений не будет поддерживать жумлу 1.5, а из всех старых будет убрана ее поддержка.
грустно, спасибо
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
грустно, спасибо

Я вам настоятельно рекомендую проапгрейдится, потому что даже официальные разработчики жумлы поддержку 1.5 то ли уже прекратили, то ли прекратят в ближайшие месяцы. А разработчики расширений и подавно. Оно того стоит, одним словом.
*

bunneh

  • Осваиваюсь на форуме
  • 10
  • 3 / 0
установил, попробовал, при попытке авторизации в любой сети пишет разные ошибки.
Для твиттера, например, "Для этой страницы отсутствует маркёр запроса. Это специальный ключ, предоставляемый приложениями..."
для мейла "Не передан идентификатор приложения в параметре client_id"
и все в таком духе, не работает ни одна сеть
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
установил, попробовал, при попытке авторизации в любой сети пишет разные ошибки.
Для твиттера, например, "Для этой страницы отсутствует маркёр запроса. Это специальный ключ, предоставляемый приложениями..."
для мейла "Не передан идентификатор приложения в параметре client_id"
и все в таком духе, не работает ни одна сеть

Как я и писал выше, по такому скудному описанию ошибок, я НИЧЕГО не могу ответить. Дайте более развернутый ответ, иначе я просто скажу, что у меня все работает, причем на двух сайтах.
*

tatjana_s

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Модуль не работает! Обращалась о помощи автор отказал. Зачем создавать тогда модули, если не помощи не отдачи?! Не теряйте время!
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Модуль не работает! Обращалась о помощи автор отказал. Зачем создавать тогда модули, если не помощи не отдачи?! Не теряйте время!

Пожалуйста, не нужно врать так открыто. Вы обратились с просьбой у вас в админке копаться при вот такой ошибке вконтакта:

{"error":"invalid_client","error_description":"client_id is incorrect"}

Вам было четко объяснено, что данная ошибка к модулю отношения не имеет, а я не оказываю данного рода поддержку. Была бы проблема с самим модулем - другое дело.
*

tatjana_s

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
Для меня это проблема с модулем! Везде все четко внесено!
*

tatjana_s

  • Осваиваюсь на форуме
  • 16
  • 0 / 0
У Вас ни одна ошибка к модулю отношения не имеет, как я посмотрю!

Объясните, почему не работает! Помогите мне, пожалуйста, иначе я просто не вижу смысла писать то, что не работает и не настраивается!
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Объясните, почему не работает! Помогите мне, пожалуйста, иначе я просто не вижу смысла писать то, что не работает и не настраивается!

Данную ошибку выдает вконтакт, а не модуль и не сайт на жумле. В чем ее причина, я НЕ знаю и искать ее у вас в админке НЕ буду. Что угодно может быть причиной, начиная от неправильного типа приложения и заканчивая глобальным затупом вконтакта.
*

M.Imperator

  • Захожу иногда
  • 128
  • 0 / 1
  • Чем смогу...
Не работает ваш модуль. :(
Joomla 2.5 и JomSocial 2.6.
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Не работает ваш модуль. :(
Joomla 2.5 и JomSocial 2.6.
А у меня работает на той же связке прекрасно.

С такими сообщениями об ошибках мы далеко не уедем...
*

M.Imperator

  • Захожу иногда
  • 128
  • 0 / 1
  • Чем смогу...
Вот ошибка вконтакте:
Код
{"error":"invalid_client","error_description":"client_id is incorrect"}

Примерно, тоже самое происходит и с facebook.
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
На всякий случай уточняю, что модуль давно вырос до компоненты и работает гораздо стабильнее Social Login. Купит можно тут:

http://thekrotek.com/joomla-extensions/social-authorization

Я не имею больше к нему отношения. Разработкой занимается сторонняя компания.
*

zikkuratvk

  • Глобальный модератор
  • 4809
  • 341 / 2
  • Обслуживаем проекты - дорого.
На всякий случай уточняю, что модуль давно вырос до компоненты и работает гораздо стабильнее Social Login. Купит можно тут:

http://thekrotek.com/joomla-extensions/social-authorization

Я не имею больше к нему отношения. Разработкой занимается сторонняя компания.
Интересно на чем основаны ваши заявления? :-)
У нас минимум 50 тысяч скачиваний (это только с нашего сайта) и судя по статистике не менее 10 тысяч внедрений успешных на сайты. А у вас? :-)
Я даже больше скажу по инструкции которая представлена у вас на сайте пользователь не сможет настроить провайдеров, она просто не актуальна.
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
*

czorny

  • Осваиваюсь на форуме
  • 40
  • 4 / 1
Интересно на чем основаны ваши заявления? :-)

На нескольких безуспешных попытках установить ваше расширение. Об одной из них, кстати, я писал в вашей теме поддержки (про открытие новых окон браузера в закладках), но вы сослались на особенности работы с API. Почему-то у Social Authorization таких проблем нет. Видимо, у них особое, теплое ламповое API.

У нас минимум 50 тысяч скачиваний (это только с нашего сайта) и судя по статистике не менее 10 тысяч внедрений успешных на сайты. А у вас? :-)

Вы ходить пешком и ездить на машине тоже сравниваете, да? Если не понятно, поясню: ходить пешком - бесплатно, ездить на машине стоит денег. Сравните еще дикие ягоды в лесу и в супермаркете.

Я даже больше скажу по инструкции которая представлена у вас на сайте пользователь не сможет настроить провайдеров, она просто не актуальна.

Да ну? Я, наверное, особенный какой-то, что умудрился по этой самой инструкции все настроить без проблем. А вот вы свою давно поменяли? У вас до последнего времени весела какая-то байда из 2012-го (фейсбук с тех пор пару раз уже поменял интерфейс раздела для разработчиков), и после этого у вас еще хватает совести делать замечание на эту тему.

Ах, да, и самое главное вы не поняли: я четко написал, что не имею к этому отношения давно, что бы вам ни мерещилось. Есть претензии - напишите разработчикам. А я высказал свое мнение, как пользователь, который оба расширения попробовал. Не нравится - совершенствуйтесь. Инструкцию, вот, поменяли уже. Глядишь, еще через пару лет приведете в порядок админку и фронт. Удачи, в общем.
*

zikkuratvk

  • Глобальный модератор
  • 4809
  • 341 / 2
  • Обслуживаем проекты - дорого.
На нескольких безуспешных попытках установить ваше расширение. Об одной из них, кстати, я писал в вашей теме поддержки (про открытие новых окон браузера в закладках), но вы сослались на особенности работы с API. Почему-то у Social Authorization таких проблем нет. Видимо, у них особое, теплое ламповое API.
Я помню вашу тему... Там кажется было про специфическое расширение для браузера, которое открывает в новом окне вкладки? Разница лишь в том, что в нашем случае мы открываем окно они редиректят на сайт социально сети, что не есть правильно и часто вводит в заблуждение пользователя.

Вы ходить пешком и ездить на машине тоже сравниваете, да? Если не понятно, поясню: ходить пешком - бесплатно, ездить на машине стоит денег. Сравните еще дикие ягоды в лесу и в супермаркете.
Давайте не проводить глупых сравнений, которые не имеют под собой ничего общего с действительностью. Ситуация такова, что я даже не смог зарегистрироваться используя Social Authorization, как пользователь.

Да ну? Я, наверное, особенный какой-то, что умудрился по этой самой инструкции все настроить без проблем. А вот вы свою давно поменяли? У вас до последнего времени весела какая-то байда из 2012-го (фейсбук с тех пор пару раз уже поменял интерфейс раздела для разработчиков), и после этого у вас еще хватает совести делать замечание на эту тему.
Как раз я то могу говорить об актуальности инструкций... так как у нас она актуальна, и она меняется почти каждый месяц, если в какой либо социальной сети происходят изменения и та которая расположена на сайте кротек, уже не актуальна, а во вторых без скриншотов очень сложно настроить в первый раз.

Ах, да, и самое главное вы не поняли: я четко написал, что не имею к этому отношения давно, что бы вам ни мерещилось. Есть претензии - напишите разработчикам. А я высказал свое мнение, как пользователь, который оба расширения попробовал. Не нравится - совершенствуйтесь. Инструкцию, вот, поменяли уже. Глядишь, еще через пару лет приведете в порядок админку и фронт. Удачи, в общем.
Просто с такими высказываниями как у вас. Я не понимаю, мы вас когда-то вас обидели, что ли?
Заметьте я ни когда не высказывал в ваш адрес ничего плохого и надеялся, что будет хотя бы обоснованная критика (не надо говорить об объективности, то что вы валите все в одну кучу даже не удосуживаясь проверить факты свидетельствует об обратном). Сейчас же получается, что оказывается мы плохие потому, что у нас много пользователей и то, что наш взгляд не совпадает с вашим. Не хватает только обвинения, в том, что мы его распространяем свободно :-)
Хочется уникальное расширение? ===>>>> JoomLine - Разрабатываем расширения под заказ.
Использую хостинг TimeWeb и Reg
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

EasySocial компонент для создания полноценной соцсети для Joomla

Автор siao

Ответов: 58
Просмотров: 14801
Последний ответ 03.12.2020, 17:53:40
от po-fakel
Проблема с модулем авторизации BT Login

Автор Paladinrus

Ответов: 0
Просмотров: 614
Последний ответ 28.05.2019, 14:56:06
от Paladinrus
Что такое "Nearby Groups" в Easy Social?

Автор Maffo

Ответов: 5
Просмотров: 980
Последний ответ 25.09.2018, 21:00:05
от lexxbry
Как добавить смайлики в Easy Social?

Автор Maffo

Ответов: 1
Просмотров: 1313
Последний ответ 07.09.2018, 02:29:03
от Terrelldek
Как делать круглый аватар в Easy Social?

Автор Maffo

Ответов: 8
Просмотров: 956
Последний ответ 31.08.2018, 16:16:51
от lexxbry