0 Пользователей и 1 Гость просматривают эту тему.
  • 2 Ответов
  • 1730 Просмотров
*

azovkor

  • Осваиваюсь на форуме
  • 14
  • 2 / 0
  • Начальник базы торпедных катеров )
Добрый день! Сталкнулся с таким моментом. После переноса на другой хостинг Joomla 1.5+VM 1.1.9, хостер прислал письмо
Сайт не открывается корректно с нового сервера, ошибка:
Warning: require_once(/var/www/ /data/www/ /administrator/components/com_virtuemart/classes/Log/LogInit.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/ /data/www/ /administrator/components/com_virtuemart/global.php on line 80

Fatal error: require_once() [function.require]: Failed opening required '/var/www/ /data/www/ /administrator/components/com_virtuemart/classes/Log/LogInit.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/ /data/www/ /administrator/components/com_virtuemart/global.php on line 80

Я так понял что проблема с путями, точнее с отсутствием файла. В 80ой строке require_once(CLASSPATH."Log/LogInit.php");

По данному пути закинул LogInit.php и теперь жду...

Следом получил  письмо...
У вас при переносе сайта, по какой-то причине, Неправильно в конфигурации вашего сайта прописаны путы к классам VirtueMart. Вам нужно прописать правильные пути в конфигурации сайта.

Путем тыка, так сказать
В configuration.php самого сайта путей к классам VirtueMart не нашел. То что нашел, так это в /administrator/components/com_virtuemart/virtuemart.cfg.php Путь к класам прописан так define( 'CLASSPATH', ADMINPATH.'classes/' );

и еще нашел строчку define('DOWNLOADROOT', '/var/www/***/data/www/site.com.ua/'); поменял на новые данные.

В общем пока я все писал техподдержка говорит что уже все работает.

Что было не так так и не понял...
« Последнее редактирование: 22.03.2013, 18:51:42 от azovkor »
*

Serpent19

  • Захожу иногда
  • 68
  • 0 / 0
Хотелось бы знать, что сделала техподдержка.
*

Serpent19

  • Захожу иногда
  • 68
  • 0 / 0
Мне в похожем случае помогла константа JPAHT_BASE, которую я начал ставить в реквайре перед путем с файлом.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Проблема с установкой VirtueMart 1.1.4

Автор Tell

Ответов: 10
Просмотров: 4711
Последний ответ 02.01.2017, 17:28:01
от pomogu_chem_smogu
Ошибка после установки VirtueMart 1.1.4

Автор AdmbVlad

Ответов: 0
Просмотров: 1148
Последний ответ 25.12.2013, 13:39:52
от AdmbVlad
[Решено] После обновления 1.9 - В данной категории нет товаров

Автор borada

Ответов: 16
Просмотров: 9156
Последний ответ 20.02.2013, 15:55:17
от didimon
Проблемы с VirtueMart при переносе сайта с одного виртуального сервера на другой.

Автор shpok

Ответов: 5
Просмотров: 3313
Последний ответ 13.04.2012, 07:58:48
от kabo
Проблема с установкой VirtueMart_1.1.9

Автор DiogenMa

Ответов: 10
Просмотров: 3972
Последний ответ 14.02.2012, 23:41:29
от serjik