0 Пользователей и 1 Гость просматривают эту тему.
  • 42 Ответов
  • 16184 Просмотров
*

avex

  • Осваиваюсь на форуме
  • 193
  • 0
Только столкнулся с изменениями (например вместо .span теперь .col-md), еще не все пересмотрел.
Хотелось бы узнать у тех, кто пробовал - насколько удобней стало верстать, поддерживаете ли новшества?
...
Да, и кто знает, Joomla 3.1.5 включает в себя Bootstrap 3 или одну из предыдущих версий?
« Последнее редактирование: 21.08.2013, 15:04:06 от b2z »
Думай, делай, двигай
*

Entombed

  • Осваиваюсь на форуме
  • 114
  • 11
  • Ума палата ... да ключ потерял
Только столкнулся с изменениями (например вместо .span теперь .col-md), еще не все пересмотрел.
http://getbootstrap.com/getting-started/#migration  - список изменений
Ничто не вечно под луной
*

b2z

  • Support Team
  • 7470
  • 743
  • Разраблю понемногу
Joomla 3 не будет переходить на BS3. Вместе с Joomla 3 будет идти версия BS2. На данный момент это версия 2.3.2.

Bootstrap 3 появится не раньше Joomla 4. Темы, в которых шло это обсуждение:
Switching to 3.x Boostrap on a 'set' schedule is premature IMO
EXODUS V. INFLUX to Joomla! based on Joomla!'s Standardization of Bootstrap
*

avex

  • Осваиваюсь на форуме
  • 193
  • 0
Спасибо. 4-ка, если не изменяет память, должна весной 14-го выйти?
И как вам изменения? Например, вместо единожды записанного .span, теперь нужно будет писать .col- (и для каждого типоразмера экрана свое значение).
Думай, делай, двигай
*

b2z

  • Support Team
  • 7470
  • 743
  • Разраблю понемногу
Версия 3.2
    Сентябрь 2013
Версия 3.5
    Март 2014 (LTS релиз)
Версия 4.0
    Сентябрь 2014
Версия 4.1
    Март 2015
Версия 4.2
    Сентябрь 2015
Версия 4.5
    Март 2016 (LTS релиз)
*

RAZORG1991

  • Давно я тут
  • 350
  • 6
Ну я вот щас верстаю шаблончик на третьем бутстрапе, правда под Joomla 2.5, в принципе мне нравиться новый grid-system, получше чем в версии бутстрап 2. И с responsive тоже немного изменения произошли, а так вроде все как и было.
*

1day

  • Осваиваюсь на форуме
  • 162
  • 1
Версия 4.5
    Март 2016 (LTS релиз)
если 3 бутстрап будет включен только в 2016 году, а он вышел уже сейчас в 2013... Мне кажется, надо пока не поздно до выхода версии Joomla 3.5 делать переход на новую версию Бутстрапа. Пока наступит весна 2016, уже и 3 версия Бутстрапа успеет морально устареть...
*

voland

  • Профи
  • 9526
  • 422
  • Эта строка съедает место на вашем мониторе
если 3 бутстрап будет включен только в 2016 году, а он вышел уже сейчас в 2013... Мне кажется, надо пока не поздно до выхода версии Joomla 3.5 делать переход на новую версию Бутстрапа. Пока наступит весна 2016, уже и 3 версия Бутстрапа успеет морально устареть...
Кстати да, повторяется ситуация с mootools, года 4 лишних его держали в ядре..
*

Alldar

  • Тестеры
  • 1500
  • 185
Какой смысл перехода на bootstrap 3 для Joomla сейчас? Потерять всех коорпоративных клиентов которым нужна подержка тогда же ie8?
Пожалуйста не дублируйте сообщения в личку/skype/google+. Все вопросы задавайте на форуме! Спасибо!

Клуб шаблонов для Joomla - NorrTheme
*

voland

  • Профи
  • 9526
  • 422
  • Эта строка съедает место на вашем мониторе
Кстати.. li.ru глючит что ли?
У меня на блоге ВНЕЗАПНО ослики пропали
*

voland

  • Профи
  • 9526
  • 422
  • Эта строка съедает место на вашем мониторе
Другой сайт на Яндексе дает 7% старым ишакам..

Реально так мало?
*

1day

  • Осваиваюсь на форуме
  • 162
  • 1
Какой смысл перехода на bootstrap 3 для Joomla сейчас? Потерять всех коорпоративных клиентов которым нужна подержка тогда же ie8?
весной 2014 заканчивается поддержка Windows XP и всем придется перейти на Windows 7/8, а там есть уже IE9.
Если Microsoft заканчивает поддержку весной 2014, то зачем же Joomla поддерживать будет "пенсионеров" до весны 2016 года? (я даже и слышать не хочу о тестовых версиях 4.0, 4.1, 4.2) Зачем столько времени тащить на себе рудимент? Надо на форуме Joomla.org начать бунт за Бутстрап 3.

P.S. так называемые "копроративные" могут делать сайты хоть на Joomla 1.5, да и хоть на Joomla 2.5 - для них в самый раз, "проверенная стабильная система", как они любят говорить. Зачем же из-за этого останавливать развитие еще и новых версий Joomla то?
*

b2z

  • Support Team
  • 7470
  • 743
  • Разраблю понемногу
Joomla старается придерживаться такой политики - никаких изменений, которые обратно несовместимы. Только в новой версии - это будет четверка.
*

1day

  • Осваиваюсь на форуме
  • 162
  • 1
Joomla старается придерживаться такой политики - никаких изменений, которые обратно несовместимы. Только в новой версии - это будет четверка.
вот сейчас текущая долгострачная 2.5 версия, она без нативного бутстрапа. так почему бы в следующей долгосрочной стабильной 3.5 сразу не сделать новый бутстрап 3, перешагнув бустрап 2. потому что "корпоративные клиенты" не делают же сайты на "тестовых версиях 3.1, 3.2"
*

Fedor Vlasenko

  • Профи
  • 3806
  • 698
  • Все начинается с Value
1day кто вам мешает на фронте прикреплять, что голове вздумается. Например у меня лично, мнение, что разработчики вообще не должны привязывать ни чего к фронту. Дать на откуп дизайнерам и фронтэндчикам свою работу. Они же всовывают всякую хрень для популярности и простой быстрой разработки. Навязывая тем самым функциональность и дизайн. И рассказывают как классно иметь 2 js фреймворка так вот мы вам еще  Bootstrap дабавим ну и для прочности подстрахуемся еще одним фреймворком или smc  :laugh:
*

b2z

  • Support Team
  • 7470
  • 743
  • Разраблю понемногу
вот сейчас текущая долгострачная 2.5 версия, она без нативного бутстрапа. так почему бы в следующей долгосрочной стабильной 3.5 сразу не сделать новый бутстрап 3, перешагнув бустрап 2. потому что "корпоративные клиенты" не делают же сайты на "тестовых версиях 3.1, 3.2"
3.0, 3.1 и 3.2 не тестовые версии, а версии с краткосрочной поддержкой! Вообщем такие изменения не вносятся в major версии (1,2,3). Думаю что в 4 будет BS3!
*

wfedin

  • Живу я здесь
  • 1290
  • 102
Они же всовывают всякую хрень для популярности и простой быстрой разработки. Навязывая тем самым функциональность и дизайн. И рассказывают как классно иметь 2 js фреймворка так вот мы вам еще  Bootstrap дабавим ну и для прочности подстрахуемся еще одним фреймворком или smc  :laugh:
+999 на фронте нафиг не нужен.
*

1day

  • Осваиваюсь на форуме
  • 162
  • 1
1day кто вам мешает на фронте прикреплять, что голове вздумается. Например у меня лично, мнение, что разработчики вообще не должны привязывать ни чего к фронту. Дать на откуп дизайнерам и фронтэндчикам свою работу. Они же всовывают всякую хрень для популярности и простой быстрой разработки. Навязывая тем самым функциональность и дизайн. И рассказывают как классно иметь 2 js фреймворка так вот мы вам еще  Bootstrap дабавим ну и для прочности подстрахуемся еще одним фреймворком или smc  :laugh:
Проблема не в том, чтобы подключить самому Бутстрап 3 для шаблона. Проблема в том, что рекомендуется использовать как можно меньше фраимворков на сайте, дабы скорость загрузки была наилучшая. Поэтому нужна нативная поддержка Бутстрапа 3. Чтобы не приходилось много чего лишнего и стороннего подключать.
3.0, 3.1 и 3.2 не тестовые версии, а версии с краткосрочной поддержкой! Вообщем такие изменения не вносятся в major версии (1,2,3). Думаю что в 4 будет BS3!
До Joomla 4.5 - до весны 2016! К этому времени уже наверняка выйдет Бустрап 4, а Joomla только-только на устаревший бустпрап 3 перейдет. Вот даже между бустрапом 1 и 2 времени не особо много прошло.

P.s. ну понятное дело, когда у тебя сайт-визитки с 10 страницами, то нафиг ничего не нужно, можно даже и на Joomla 1.5 сайт лепить. Но я говорю о больших порталах, где посещаемость несколько тысяч чел/сутки. Тут важно все самое новое применять, в том числе и различные улучшения в дизайне, в нашу новую эру мобильных устройств и 3g/4g соединения со смартфонов скорость загрузки сайта как никогда стала важна.
*

Arkadiy

  • Группа развития
  • 5351
  • 440
  • Крепитесь, други.
Вы просто не понимаете насколько дорогое будет движение перехода на новую версию бутстрапа. Если сейчас в стабильной версии это сделать, то у всех сопутствующих компонентов все порушится и разработчикам придется вкладывать время и деньги в приведение своего добра в совместимость с новыми реалиями. Никто из разработчиков это не поймет. Таковы реалии Joomla.
*

RAZORG1991

  • Давно я тут
  • 350
  • 6
Из-за чего весь этот ПЕРЕПОЛОХ? :o
Ну не исполозует Joomla новые версии фреймов! И что? ::) Присоединяюсь к Fedor Vlasenko и wfedin на фронтэнде фрейм нафиг не нужен из ядра! Подключайте сами на фронте все, что хотите и делайте шаблон как хотите!
Использовать фреймы (и рассказывать клиентам байки про то, что мы мол делаем все по последнему слову техники и дизайнерской мысли  ;) ) или же вообще ничего не использовать и писать вручную (и рассказывать клиентам, что мы мол такие суперпрофи и нам никакие бутстрапы не нужны  :P ) - дело сугубо личное.
Что касаемо бэкэнда, то тут честно говоря как-то пофиг, на каком фрейме (и какой версии сделан). Это скорее даже дань моде и маркетингу, что мол теперь даже админка Joomla и на яблокофонах нормально отображается, и в век мобилизации иметь отзывчивый дизайн даже админской части - ПИПЕЦ КАК КРУТО! Хотя до этого как-то жили и на не отзывчивом дизайне админки и все было норм, никто не плакал ;)  Ну покажите мне хоть одного человека, который будит редактировать материалы сайта или переделывать что-то координальное с мобильника?))) Ну с планшета еще ладно - парочку статей добавить.

Вы просто не понимаете насколько дорогое будет движение перехода на новую версию бутстрапа. Если сейчас в стабильной версии это сделать, то у всех сопутствующих компонентов все порушится и разработчикам придется вкладывать время и деньги в приведение своего добра в совместимость с новыми реалиями. Никто из разработчиков это не поймет. Таковы реалии Joomla.

Ну не знаю так ли все порушится?))) По-моему разработчики все как-то по-своему делают, как душе заблагорассудится))) Переписать фронтэнд любого расширения на бутстрап, чтобы расширение на выходе имело отзывчивый дизайн не составить трудности даже для обычного верстальщика)))
*

Arkadiy

  • Группа развития
  • 5351
  • 440
  • Крепитесь, други.
Я не говорил про трудности, я говорил про ресурсы.
*

1day

  • Осваиваюсь на форуме
  • 162
  • 1
Ну не исполозует Joomla новые версии фреймов! И что? ::) Присоединяюсь к Fedor Vlasenko и wfedin на фронтэнде фрейм нафиг не нужен из ядра! Подключайте сами на фронте все, что хотите и делайте шаблон как хотите!
и будет сайт грузиться не 1-2 секунды в итоге, а 8-9 секунд. Скорость загрузки сайта крайне важна, в том числе и для поисковых систем. Я не думаю, что это настолько трудно переписать шаблоны, ведь изменения есть, но их не так же много, как было при переходе с обычного дизайна на бустрап. Никто никого же не заставляет сейчас пользоваться новой версий 3.1, 3.2 - они с кратким сроком, на них все новое обкатывается, поэтому, пока не поздно, пока не вышла долгосрочная 3.5 весной 2014, надо максимум все новое и последнее к выходу 3.5 добавить, чтобы уже потом еще на 2-3 года на этом всем сидеть. А если изначально что-то устаревшее добавлять в Joomla, то к концу эксплуатации Joomla 3.5, на ней все настолько морально устареет, что опять Joomla будет в роли "догоняющих".

Использовать фреймы (и рассказывать клиентам байки про то, что мы мол делаем все по последнему слову техники и дизайнерской мысли  ;) ) или же вообще ничего не использовать и писать вручную (и рассказывать клиентам, что мы мол такие суперпрофи и нам никакие бутстрапы не нужны  :P ) - дело сугубо личное.
Что касаемо бэкэнда, то тут честно говоря как-то пофиг, на каком фрейме (и какой версии сделан). Это скорее даже дань моде и маркетингу, что мол теперь даже админка Joomla и на яблокофонах нормально отображается, и в век мобилизации иметь отзывчивый дизайн даже админской части - ПИПЕЦ КАК КРУТО! Хотя до этого как-то жили и на не отзывчивом дизайне админки и все было норм, никто не плакал ;)  Ну покажите мне хоть одного человека, который будит редактировать материалы сайта или переделывать что-то координальное с мобильника?))) Ну с планшета еще ладно - парочку статей добавить.
я не говорю про админку, я имею ввиду фронт - то, что видят пользователи сайта. ну если у тебя черно-белый телефон за 2 т.р. и ты никогда с мобилы по острой необходимости не залазил на сайт/свой vps, то это не означает, что это никому не нужно.

Вот я готов объяснить и доказать, что новая админка в Joomla 2.5 намного лучше, и это не какие-то айфоновые понты (у меня у самого за 2 т.р. но у меня megafon login c 4.0.4), и например когда я был за городом этим летом целую неделю, то я ощутил всю прелесть "отзывчивого" дизайна. Потому что когда надо было чистить файлы логов на VPSнике, то пришлось заходить в админку isp manager, вводить логин/пароль, потом переходить в нужную дирекоторию, выделять файлы и удалять их. Там не отзывчивый дизайн, но с отзывчивым это было бы в разы быстрее и намного удобнее все сделать.

Про Joomla и добавление новостей: Не надо писать про айфон-понты в админке. Мне например админка в Joomla 3.x была очень удобна, опять же когда я был за городом и не было ПК рядом. Вот вышел новый клип, я зашел в YouTube, скопировал код и потом зашел в админку на Joomla 3.x, добавил быстро и удобно все и запостил на главной странице. И это намного удобнее, чем постоянно увеличивать/уменьшать вид в админке Joomla 2.5, да и еще с трудом попадать по нужным кнопкам(у меня тел не лопата 6 дюймовая).

Новая админка в Joomla 3.x - это не понты для "афонов", как считает RAZORG1991, это действительно современная необходимость. Мы живем сейчас в эпоху мобильных устройств, и даже в VK в августе с мобильных устройств заходило 33% посетителей. Сейчас достаточно иметь телефон всего за 2 т.р., чтобы оценить все это, так что это далеко уже давно не какие-то там понты. Это жизненная необходимость. Ты же не каждый день сидишь за компом и не все время, бывает едешь в дороге, или за городом/в отпуске, и совершать какие-либо действия в адаптивном дизайне действительно намного удобнее, легче, и занимаем меньше времени.
*

Arkadiy

  • Группа развития
  • 5351
  • 440
  • Крепитесь, други.
Вы не сравнивайте с бутстрапом или без, вы скажите что вы выиграете, как владелец смартфона, заходящий с него в админку, при смене одного бутстрапа другим?
*

SmokerMan

  • Профи
  • 5334
  • 690
Переписать фронтэнд любого расширения на бутстрап, чтобы расширение на выходе имело отзывчивый дизайн не составить трудности даже для обычного верстальщика)))
Когда кардинально меняется разметка, приходиться все заново адаптировать под админку. Пересматривать все макеты и т.д. Извините, но кому это надо будет?
Мне если честно хватает того, что они мудрят в самом фреймворке от версии к версии, а переделывать еще для каждой версии шаблоны и что бы это работало на всех версиях одинаково, это уж извольте, кроме как танцем с бубном ничем не назовешь.

я не говорю про админку, я имею ввиду фронт - то, что видят пользователи сайта. ну если у тебя черно-белый телефон за 2 т.р. и ты никогда с мобилы по острой необходимости не залазил на сайт/свой vps, то это не означает, что это никому не нужно.
а вам и ответили - делайте фронт как хотите и на чем хотите. Если проблема с отключением дефолтных скриптов, то статей и уже готовых плагинов на данном форуме полно.
*

Pazys

  • Практически профи
  • 1846
  • 237
  • <a>А где я ошибся-то?</b>
если 3 бутстрап будет включен только в 2016 году, а он вышел уже сейчас в 2013... Мне кажется, надо пока не поздно до выхода версии Joomla 3.5 делать переход на новую версию Бутстрапа. Пока наступит весна 2016, уже и 3 версия Бутстрапа успеет морально устареть...

Морально устареть? Почитайте про спецификации CSS2.1 они разрабатывались 10 лет и сами по себе являются версией CSS2 переходящей в CSS3, а CSS3 спецификации ! до сих пор разрабатываются.

Вообщем с 98 года ничего конкретного не изменилось. Минимум типа: <font><b> и ввели тени, градиенты, скругления

Что морально устареет в Бутстрапе-то? span-xx? Не стоит так радикально новаторствовать, но и не надо быть обскурантом.


К тому-же поддержка бутстрапа ядром - для меня как сумка с карманом для телефона - есть, но не пользуюсь. Бутстрапом пользуюсь, но не тем, что в самой Joomla.
 
Ишак меня нюхал ...
Если помог - плюсуйте в карму.
*

RAZORG1991

  • Давно я тут
  • 350
  • 6
и будет сайт грузиться не 1-2 секунды в итоге, а 8-9 секунд.

И кто это вам сказал, что если фрейм подключается из ядра, то сайт будет грузиться быстрее? Фрейм - он в любом виде фрейм! И браузеру абсолютно пофиг как он подключается, потому как загружает он одинаковый набор стилей, что из ядра, что из вашего линка. Он грузит килобайты, а не разбирается мол "Так - этот из ядра значит загружу-ка я его быстрее, а вот этот линком подключается - не с этим надо подумать". Я вам больше скажу - браузеру даже абсолютно пофиг какая у вас cms стоит ;)
А если вам надо поотключать дефолтные скрипты (как уже было сказано SmokerMan) и не подключать тот же самый "устаревший" по вашему мнению бутстрап 2.3.2, то кто вам мешает?
« Последнее редактирование: 05.09.2013, 13:04:16 от RAZORG1991 »
*

vmir

  • Захожу иногда
  • 17
  • 4
 !
А если вам надо поотключать дефолтные скрипты (как уже было сказано SmokerMan) и не подключать тот же самый "устаревший" по вашему мнению бутстрап 2.3.2, то кто вам мешает?

Joomla привлекала разработчиков сайтов большим набором компонентов, модулей, плагинов. И на данный момент разработчики компонентов уже начинают активно использовать бутстрап 2. А это значит, что если хочешь использовать бутсртап 3, то: 1) придется отказаться от этих компонентов (а со временем их число только увеличится), 2) часть функционала сайта придется реализовывать самому, 3) неизвестно, какие сюрпризы ожидают тебя в версии 3.5 и далее (отметим, что стандартными средствами CMS бутстрап 2 не отключается (!), в админке под него уже заточен конфигуратор модулей и т.д.).
С другой стороны, использование устаревших фрэймвоков - плохой вектор развития,  даже в собственных шаблонах. Кто бы что не сказал, но бутстрап 2 устарел. Зайдите на сайт bootstrap, версия 2 задвинута в отдельную категорию, ссылки на которую с главной страницы getbootstrap.com нет. Уже сейчас Google пытается выдать примеры и инфу по 3-ей версии, а через пол года bootstrap 2 будет интересен только Joomlaводам.
Как видим есть серьезная проблема с отключением дефолтных скриптов и использования нового bootstrap 3, так как возникает нестыковка с рядом компонентов и нововведениями в CMS. И есть не меньшая проблема, с использованием bootstrap 3. А все это происходит из-за того, что разработчики Joomla, выбрали неверную шизофренически сложную тактику развития своей CMS. Вместо того, чтобы направить усилия вглубь на создание единичного качественного продукта, они направляют усилия в ширь и наплодили кучу версий, а теперь не успевают все это поддерживать и вовремя обновлять, навязывают какой-то хлам во фронтенде и по сути кошмарят разработчиков. Мой текущий сайт будет на Joomla, но следующий... увольте, выберу себе что-то более потребное.
*

romper7stomper

  • Новичок
  • 8
  • 0
Ну сейчас то вроде уже поновее версия
*

DeadButHappy

  • Захожу иногда
  • 14
  • 0
весной 2014 заканчивается поддержка Windows XP и всем придется перейти на Windows 7/8, а там есть уже IE9.
1. То что кончается поддержка, практически не влияет на количество пользователей WindowsXP.
Из своего предыдущего опыта. На бывшей работе примерно 40машин возрастом 5-6 лет. Покупают по 1-2 компа в год.
На эти старые компы шла лицензия OEM. Ни о какой WinSeven и речи не может быть. Потому что 1. Она будет тормозить. 2. Никто из бюджета не даст деньги на вторую покупку лицензии на одну и туже машину.
2. На WinSeven идет IE8, а так как все руководители работают или хотя бы контролируют работу с сайтом Госзакупок, то у них в большинстве рабочий браузер IE, и в 99% случаев его никто не обновляет до 9 или 10.
--
PS.
IE8 умрет только когда выйдут из строя сами компьютеры с купленной операционной системой winXP,
и то останется маленькая часть на WinSeven.
---
PPS.
А ради чего собственно менять версии BootStrap на неподдерживающие IE8 ?
Ради тех для кого эти сайты делаются? Но им это не нужно.
Только ради разработчиков которые хотят разрабатывать лишь на новых версиях и которым пофиг на несовместимость с некоторыми пользователями??


« Последнее редактирование: 23.04.2014, 10:30:13 от DeadButHappy »
*

AlekVolsk

  • Профи
  • 6312
  • 336
На WinSeven идет IE8, а так как все руководители работают или хотя бы контролируют работу с сайтом Госзакупок, то у них в большинстве рабочий браузер IE, и в 99% случаев его никто не обновляет до 9 или 10.
Гос.закупки сейчас прекрасно работают на любой версии ослика, и на 8-ке, и на 9-ке, и выше - проверено. К криптопро идет аддон для фокса, на котором с этим аддоном прекрасно работают все сайты, требующие авторизации посредством сертификатов, в т.ч. гос.закупки и сбербанк-аст. И я давно обновил ослика на всех копиях вин7 до 11й версии.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Меню исчез при уменьшении экрана. Шаблон YT Katana

Автор aniangeless

Ответов: 1
Просмотров: 24
Последний ответ 23.09.2017, 01:23:36
от aniangeless
Табы в шаблон

Автор мираж

Ответов: 0
Просмотров: 32
Последний ответ 18.09.2017, 11:57:43
от мираж
Joomla видит только шаблон по-умолчанию

Автор dmmur

Ответов: 1
Просмотров: 115
Последний ответ 11.09.2017, 18:43:54
от kotstantin
Копирование папок components/com_content/ в шаблон

Автор Mnojitell

Ответов: 3
Просмотров: 121
Последний ответ 07.09.2017, 11:34:57
от Mnojitell
При редактировании материала не работает кнопка "Сохранить". Шаблон oliveriolite

Автор Alxndr

Ответов: 3
Просмотров: 361
Последний ответ 06.08.2017, 18:20:20
от JerryHilfiger