Когда пользователь добавляет картинку в материал она пропадает, в чем может быть причина?

  • 5 Ответов
  • 270 Просмотров

0 Пользователей и 1 Гость просматривают эту тему.

*

RicoID

  • Осваиваюсь на форуме
  • ***
  • 77
  • 0
Всем привет! Столкнулся с такой проблемой. Пользователь добавляет картинку в материал, затем нажимает "сохранить" т.е. он добавляет статью на сайт, по правильному она не отображается до тех пор, пока я её не проверю и не опубликую. Так вот, когда я её открываю для просмотра, в менеджере материалов, в ней нет картинки которую добавлял пользователь, она заливается в папку пользователя, как положено но не отображается! Решил добавить статью под логином админа, непосредственно с сайта, картинки на месте! :(. Я думал это проблема из-за того, что я задал "Путь к каталогу файлов: images/stories/$id" т.е. чтобы каждому пользователю создавалась своя папка для изображений. Убрал, ничего не изменилось. Подскажите пожалуйста в чем может быть причина, может я где-то "галочку" забыл поставить или типа того?

Пропадает не только картинка, Но и кнопка "подробнее" тоже пропадает.

« Последнее редактирование: 30.11.2016, 13:02:44 от RicoID »

*

Гонсалес

  • Захожу иногда
  • **
  • 17
  • 0
Это хорошо, что вы проверили, как это все от админа работает. Но надо было бы еще зайти под пользователем и проверить. После того как картинка добавлена в поле редактора, переключите редактор в режим просмотра кода на всякий случай - посмотреть что там за код для картинки, есть ли там вообще HTML. Звучит так, как будто у этого профиля пользователя JCE запрещен HTML. Попробуйте в этом покопаться. По очереди разрешать ему какие-нибудь пункты и смотреть что будет.


*

Гонсалес

  • Захожу иногда
  • **
  • 17
  • 0
и кнопка "подробнее" тоже отсутствует.
какие кнопки видят пользователи в редакторе настраивается в профилях JCE

*

RicoID

  • Осваиваюсь на форуме
  • ***
  • 77
  • 0
Это хорошо, что вы проверили, как это все от админа работает. Но надо было бы еще зайти под пользователем и проверить. После того как картинка добавлена в поле редактора, переключите редактор в режим просмотра кода на всякий случай - посмотреть что там за код для картинки, есть ли там вообще HTML. Звучит так, как будто у этого профиля пользователя JCE запрещен HTML. Попробуйте в этом покопаться. По очереди разрешать ему какие-нибудь пункты и смотреть что будет.
Можно по подробнее, где найти пункты связанные с HTML?

*

RicoID

  • Осваиваюсь на форуме
  • ***
  • 77
  • 0
Можно по подробнее, где найти пункты связанные с HTML?
Вроде проблема решилась! Нашел тему с проблемой в точности как у меня: http://joomlaforum.ru/index.php?topic=63040.0