0 Пользователей и 1 Гость просматривают эту тему.
  • 7 Ответов
  • 524 Просмотров
*

wishlight

  • Живу я здесь
  • 4932
  • 289 / 1
  • от 150 руб быстрый хостинг в Москве
Сегодня столкнулся с интересным багом на сайте клиента. Было меню и в нем алиасы для материалов. Все отлично работало. Но в один прекрасный момент (бекапов до момента нет и как оказалось раньше октября 2017) одно из меню стало выдавать все ссылки 404, хотя материалы есть и включены, как само меню и пункты меню. Собственно, ничего кроме автоматических обновлений не делалось. До этого была похоже кривая миграция с 1.5 - 2.5 на 3. Может у кого-нибудь была похожая ситуация и он подскажет где искать в первую очередь? Пока сам сильно не вникал, потому что ночь и спать хочется.
*

Aleks.Denezh

  • Живу я здесь
  • 3406
  • 427 / 4
Re: Непонятный для меня баг с меню
« Ответ #1 : 18.02.2018, 22:20:25 »
было такое помогло нажатие на кнопку перестроить меню..
*

wishlight

  • Живу я здесь
  • 4932
  • 289 / 1
  • от 150 руб быстрый хостинг в Москве
Re: Непонятный для меня баг с меню
« Ответ #2 : 18.02.2018, 22:22:14 »
Перестроил меню, категории, пункты меню, ничего не изменилось. В самом начале помню проверял все эти ссылки и было все ок. Не приложу ума что случилось. Завтра распакую на локалхосте ...
*

Aleks.Denezh

  • Живу я здесь
  • 3406
  • 427 / 4
Re: Непонятный для меня баг с меню
« Ответ #3 : 18.02.2018, 22:31:52 »
Перестроил меню, категории, пункты меню, ничего не изменилось. В самом начале помню проверял все эти ссылки и было все ок. Не приложу ума что случилось. Завтра распакую на локалхосте ...
попробуйте исправить базу, посмотрите что в таблице, может какой компонент для ссылок есть и заглючил ?
*

kern.USR

  • Давно я тут
  • 827
  • 68 / 1
Re: Непонятный для меня баг с меню
« Ответ #5 : 19.02.2018, 08:13:26 »
У меня недавно встречалось тоже нечто подобное. Только у меня алмазы пустыми оказались . Также после обновления вдруг 404 на материалы стали валиться. Я в меню - там в алиасах пусто. Ставлю новый, сохраняю - пусто. Иду в базу - там все на месте. Перестроил меню - слетели остальные алиасы. В итоге переписал из свежего дистрибутива libraries  и все заработало
Позже коллега сказал, что было подобное у него. Причина вродебы в том, что по каким-то необъяснимым причинам права 400 на некоторые Файлы встали. Хотя я такого не замечал
*

wishlight

  • Живу я здесь
  • 4932
  • 289 / 1
  • от 150 руб быстрый хостинг в Москве
Re: Непонятный для меня баг с меню
« Ответ #6 : 19.02.2018, 12:02:24 »
В общем после еще одной перестройки и пересохранения каждого пункта меню с указанием на статью вроде заработало. assets уже другое дело назначить. Достаточно же будет пересоздать все меню без ассетов и перекинуть категории с материалами в тестовую категорию и обратно?
*

wishlight

  • Живу я здесь
  • 4932
  • 289 / 1
  • от 150 руб быстрый хостинг в Москве
Re: Непонятный для меня баг с меню
« Ответ #7 : 20.02.2018, 10:08:25 »
В общем всем спасибо. Я так понял что-то с assets_id было, точнее их не было. При пересохранении они назначились и вроде все ок.
Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Правильное размещение "меню" и "подменю"

Автор Teoscorpion91

Ответов: 3
Просмотров: 239
Последний ответ 09.11.2021, 19:18:11
от effrit
Публикация 1 материала в два меню и в две категории

Автор samell79

Ответов: 1
Просмотров: 148
Последний ответ 29.10.2021, 10:27:37
от wishlight
Ошибка при Создание пунктов меню

Автор RomanRomanivich

Ответов: 0
Просмотров: 161
Последний ответ 23.09.2021, 15:01:14
от RomanRomanivich
[РЕШЕНО] Offcanvas меню не открывается на сайте ни через компьютер, ни телефон

Автор Cloddy

Ответов: 6
Просмотров: 1220
Последний ответ 13.08.2021, 23:25:50
от Cloddy
Не отображается меню сайта

Автор МихаилЧ

Ответов: 0
Просмотров: 256
Последний ответ 03.08.2021, 19:15:39
от МихаилЧ