0 Пользователей и 1 Гость просматривают эту тему.
  • 4 Ответов
  • 2079 Просмотров
*

Андрей Нестеров

  • Захожу иногда
  • 207
  • 6 / 0
Переход на версию PHP 7.х
« : 09.10.2018, 16:46:11 »
Доброго времени суток!

В админке не так давно появилось предупреждение о необходимости перехода на новую версию PHP - рекомендуется 7.х. У меня была 5.6.2. У хостера три варианта: 7.0, 7.1 и 7.2. На последних двух сайт перестал работать, на 7.0 - все хорошо, но в админке Joomla и на эту версию (7.0.32) появилось точно такое же предупреждение.

Стоит ли обращать на это внимание? Если да, то как определить, почему сайт не работает на версиях 7.1 и 7.2? Как выяснить, какие компоненты/модули конфликтуют с новой версией PHP?
*

NewUsers

  • Живу я здесь
  • 2270
  • 205 / 0
  • +375 (25) 627-16-99 (WhatsApp, Telegram)
Re: Переход на версию PHP 7.х
« Ответ #1 : 09.10.2018, 16:54:40 »
Как выяснить, какие компоненты/модули конфликтуют с новой версией PHP?
А ты перейди на новую версию и увидишь какие ошибки у тебя будут...
Больше чем уверен что будет вот такая ошибка Ошибка: 0 - Using $this when not in object context, но решение есть...
Может и другие будут но они все решаемы!
Занимаюсь создание расширений для Joomla 3.9.x или выше | Доработка и настройка сайтов. Работаю по факту (без всяких предоплат). Оплата только на ЮMoney (бывшие Яндекс.Деньги). Помогу с переездом на PHP 7.x и исправлю ошибки PHP.
Занимаюсь создание Интернет магазинов с нуля на собственном компоненте + оптимизация загрузки страницы (после предоставляю техподдержку).
*

draff

  • Гуру
  • 5803
  • 432 / 7
  • ищу работу
Re: Переход на версию PHP 7.х
« Ответ #2 : 09.10.2018, 16:55:46 »
Как выяснить, какие компоненты/модули конфликтуют с новой версией PHP?
Отключить все сторонние расширения и переключить на стандартный шаблон, и включать поочередно.
*

Андрей Нестеров

  • Захожу иногда
  • 207
  • 6 / 0
Re: Переход на версию PHP 7.х
« Ответ #3 : 11.10.2018, 13:56:13 »
Цитировать
А ты перейди на новую версию и увидишь какие ошибки у тебя будут...

При переходе на версию 7.1: "Страница недоступна Сайт armymusic.ru пока не может обработать этот запрос. HTTP ERROR 500"

Цитировать
Отключить все сторонние расширения и переключить на стандартный шаблон, и включать поочередно.

На локалке (openserver) получится все это проделать?



Чтобы оставить сообщение,
Вам необходимо Войти или Зарегистрироваться
 

Из FAQ: Переход с 2.5 на 3.х

Автор Magnum

Ответов: 167
Просмотров: 74396
Последний ответ 28.04.2022, 06:06:35
от Cherr23
Переход на PHP 8 ошибка

Автор Zegeberg

Ответов: 5
Просмотров: 2231
Последний ответ 08.06.2021, 14:51:54
от bratsk12
Переход на 7.3 версииPHP ошибка с темой

Автор peklor

Ответов: 6
Просмотров: 612
Последний ответ 18.04.2021, 23:02:35
от peklor
Обновление Joomla c 3.8.6 и переход c php 5.6

Автор buto

Ответов: 5
Просмотров: 476
Последний ответ 25.02.2021, 08:28:07
от draff
Переход на http/2

Автор artman

Ответов: 2
Просмотров: 654
Последний ответ 21.09.2020, 15:17:56
от artman